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Getting Started Guide

Preface



Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice will find this Getting Started Guide
valuable. You may be new to office software, or you may be familiar with another office suite.

What'’s in this book?

This book introduces the main components of LibreOffice:

*  Writer (word processing)
» Calc (spreadsheets)

* Impress (presentations)
» Draw (vector graphics)

* Base (database)

* Math (equation editor)

It also covers some of the features common to all components, including setup and
customization, styles and templates, macro recording, and printing. For more detail, see the user
guides for the individual components.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is the first line of support for using
LibreOffice. Windows and Linux users can choose to download and install the offline Help for use
when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select LibreOffice Help in the Help menu. If you do not
have the offline help installed on your computer and you are connected to the Internet, your
default browser will open the online Help pages on the LibreOffice website.

The Help menu also includes links to other LibreOffice information and support facilities.

Note

The options followed by a * sign in the list below are only accessible if your computer
is connected to the Internet.

* What's This? For quick tips when a toolbar is visible, place the mouse pointer over any of
the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a
more detailed explanation, select Help > What's This? and hold the pointer over the
icon. In addition, you can choose whether to activate Extended Tips using Tools >
Options > LibreOffice > General.

+ User Guides * Opens your default browser at the Documentation page of the LibreOffice
website, https://documentation.libreoffice.org/en/english-documentation/. There you will
find copies of User Guides and other useful information.

* Show Tip-of-the-Day Opens a small window with a random tip on how to use LibreOffice.

« Get Help Online * Opens your default browser at the Ask LibreOffice forum of questions
and answers from the LibreOffice community, https://ask.libreoffice.org/en/questions/.
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« Send Feedback * Opens your default browser at the Feedback page of the LibreOffice
website, https://www.libreoffice.org/get-help/feedback/. From there you can report bugs,
suggest new features and communicate with others in the LibreOffice community.

* Restart in Safe Mode Opens a dialog window where you will have the option to restart
LibreOffice and reset the software to its default settings.

« Get Involved * Opens your default browser at the Get Involved page of the LibreOffice
website, https://www.libreoffice.org/community/get-involved/. There you can choose a
topic of interest to help improve the program.

« Donate to LibreOffice * Opens your default browser at the Donation page of the
LibreOffice website, https://donate.libreoffice.org/. There you can choose to make a
donation to support LibreOffice.

* License Information Outlines the licenses under which LibreOffice is made available.

« Check for Updates * Opens a dialog window and checks the LibreOffice website for
updates to your version of the software.

* About LibreOffice Opens a dialog window and displays information about the version of
LibreOffice and the operating system you are using. This information will often be
requested if you ask the community for help or assistance with the software. (On macOS
this item is under the LibreOffice menu.)

Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based
support. In addition to the Help menu links above, there are other online community support
options available, see the table below.

Free LibreOffice support

Answers to frequently asked questions

FAQs https://wiki.documentfoundation.org/Faq

Free community support is provided by a network of experienced users

Mailing lists https://www.libreoffice.org/get-help/mailing-lists/
Free community assistance is provided in a Question & Answer formatted
Questions & Answers web service. Search similar topics or open a new one in
and https://ask.libreoffice.org/en/questions
Knowledge Base The service is available in several other languages; just replace /en/ with de,

es, fr, ja, ko, nl, pt, tr, and many others in the web address above.

The LibreOffice website in various languages
https://www.libreoffice.org/community/nic/

Mailing lists for native languages
https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about social networking
https://wiki.documentfoundation.org/Website/Web_Sites services

Native language support

Information about available accessibility options

Accessibility options https://www.libreoffice.org/get-help/accessibility/

A forum that provides support for LibreOffice, among other open source

OpenOffice Forum office suites https://forum.openoffice.org/en/forum/

Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The
Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/
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What you see may be different

lHlustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers). The
illustrations in this guide were taken from a variety of computers and operating systems.
Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You
can either use dialogs from your computer’s operating system or from LibreOffice. The
differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to
Tools > Options > LibreOffice > General and select or deselect the option Use LibreOffice
dialogs.

Icons

The LibreOffice community has created icons for several icon sets: Breeze, Colibre, Elementary,
Karasa Jaga, Sifr, and Sakapura; some are also available in a dark version. As a user you can
select your own preferred set. The icons in this guide have been taken from a variety of
LibreOffice installations that use different sets of icons. The icons for some of the many tools
available in LibreOffice may then differ from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. In the Icon style
section, choose from the drop-down list.

Notes

Some Linux distributions include LibreOffice as part of the installation and may not
include all the icon sets mentioned above. You should be able to download other
icon sets from the software repository for your Linux distribution if you wish to use
them.

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the
standard installation package. They can be added back by downloading and installing
them as extensions from https://extensions.libreoffice.org/en/extensions/

Some of the previously included gallery sets are now only available as extensions;
see https://extensions.libreoffice.org/?Tags%5B%5D=49 or search for specific ones,
for example, the People Gallery,
https://extensions.libreoffice.org/en/extensions/show/people-gallery

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this book. For a
more detailed list, see the application Help.

Windows or Linux macOS equivalent Effect
Tools > Options menu LibreOffice > Preferences Access setup options
Right-click Control+click and/or right-click
. Open a context menu
depending on computer setup
Ctrl (Control) & (Command) Used with other keys
F11 H+T Open the sidebar Styles deck
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What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you
see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same
as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls to use to specify how to carry out an action. The technical
names for common controls are shown in Figure 1. In most cases the technical terms are not
used in this book, but it is useful to know them because the Help and other sources of
information often use them.

Page Style: Default
|Organizer | Page Borders | Background | Header | Footer|Sheet| 1

Page order -

@® Top to bottom, then right
2 O Left to right, then down 4 5

First page number C%

Print
[J Column and row headers Charts
O Grid Drawing objects
O Comments O Formulas
Objects/graphics Zero values

Scale
Scaling mode 6
[Reduce/enlarge printout ¢|  Scaling factor @ 2

7 [ oK ] [ Cancel l Help ] [ Reset ]

Figure 1: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).

4) Spin box (click the up and down arrows to change the number shown in the adjacent text
box, or type in the text box).

5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves
your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and the document. An example of this type is the Find & Replace dialog.
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Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0
but also includes software that differs from version to version under a variety of other Open
Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May I sell it? May | use it in my business?
Yes.

How many computers may | install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized for more than 80%, both Ul and Help) into over
46 languages, so your language probably is supported. Localisation is well under way for
another 30+ languages (50-80%) and for another 50+ languages help is more than
welcome. In addition, over 70 spelling, hyphenation, and thesaurus dictionaries are
available for languages and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: www.libreoffice.org.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several
organizations.

I am writing a software application. May | use programming code from LibreOffice in my
program?
You may, within the parameters set in the MPL and/or LGPL. Read the licenses:
https://www.mozilla.org/MPL/2.0/.

Why do | need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required for
some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition
for your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If you want to use LibreOffice features that require Java, it is important that the
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the
Advanced Options in Chapter 2 of this guide. If you do not want to use Java, you can
still use nearly all of the LibreOffice features.

How can | contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you
do not need to be a programmer. To start, check out this webpage:
https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement
at the beginning of this book. You do not have to request special permission. We request
that you share with the project some of the profits you make from sales of books, in
consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/
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What is LibreOffice?

LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is
Open Document Format (ODF), an open standard format that is being adopted by governments
worldwide as a required file format for publishing and accepting documents. LibreOffice can also
open and save documents in many other formats, including those used by several versions of
Microsoft Office.

LibreOffice includes the following components.

Writer (word processor)

Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from other components into Writer documents.
Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), EPUB,
and several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)

Calc has all of the advanced analysis, charting, and decision making features expected from a
high-end spreadsheet. It includes over 500 functions for financial, statistical, and mathematical
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D
and 3D charts, which can be integrated into other LibreOffice documents. You can also open and
work with Microsoft Excel workbooks and save them in Excel format. Calc can also export
spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe
PDF and HTML formats.

Impress (presentations)

Impress provides all the common multimedia presentation tools, such as special effects,
animation, and drawing tools. It is integrated with the advanced graphics capabilities of
LibreOffice Draw and Math components. Slideshows can be further enhanced using Fontwork
special effects text, as well as sound and video clips. Impress can open, edit and save Microsoft
PowerPoint presentations and can also save your work in numerous graphics formats.

Draw (vector graphics)

Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to
3D artwork. Its Smart Connectors feature allows you to define your own connection points. You
can use Draw to create drawings for use in any of the LibreOffice components, and you can
create your own clip art and then add it to the Gallery. Draw can import graphics from many
common formats and save them in many formats, including PNG, GIF, JPEG, BMP, TIFF, SVG,
HTML and PDF.

Base (database)

Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is
much the same as in other popular database applications. Base provides many new features,
such as the ability to analyze and edit relationships from a diagram view. Base incorporates two
relational database engines, HSQLDB and Firebird. It can also use PostgreSQL, dBASE,
Microsoft Access, MySQL, Oracle, or any ODBC compliant or JDBC compliant database. Base
also provides support for a subset of ANSI-92 SQL.
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Math (formula editor)

Math is the LibreOffice formula or equation editor. You can use it to create complex equations
that include symbols or characters not available in standard font sets. While it is most commonly
used to create formulas in other documents, such as Writer and Impress files, Math can also
work as a standalone tool. You can save formulas in the standard Mathematical Markup
Language (MathML) format for inclusion in web pages and other documents not created by
LibreOffice.

Advantages of LibreOffice

Here are some of the advantages of LibreOffice over other office suites:

No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export)
are free with LibreOffice. There are no hidden charges now or in the future.

Open source. You can distribute, copy, and modify the software as much as you wish, in
accordance with the LibreOffice Open Source licenses.

Cross-platform. LibreOffice runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, macOS, and Linux.

Extensive language support. The LibreOffice user interface, including spelling,
hyphenation, and thesaurus dictionaries, is available in over 100 languages and dialects.
LibreOffice also provides support for both Complex Text Layout (CTL) and Right to Left
(RTL) layout languages (such as Urdu, Hebrew, and Arabic).

Consistent user interface. All the components have a similar “look and feel”, making
them easy to use and master.

Integration. The components of LibreOffice are well integrated with one another.

— All the components share a common spelling checker and other tools, which are used
consistently across the suite. For example, the drawing tools available in Writer are
also found in Calc, with similar but enhanced versions in Impress and Draw.

— You do not need to know which application was used to create a particular file. For
example, you can open a Draw file from Writer; it will open automatically in Draw.

Granularity. Usually, if you change an option, it affects all components. However,
LibreOffice options can be set at a component level or even at document level.

File compatibility. In addition to its native OpenDocument formats, LibreOffice includes
support for opening and saving files in many common formats including Microsoft Office,
HTML, XML, WordPerfect, Lotus 1-2-3, and PDF.

No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for the
Advancement of Structured Information Standards). These files can easily be unzipped
and read by any text editor, and their framework is open and published.

You have a voice. Enhancements, software fixes, and release dates are community-
driven. You can join the community and affect the course of the product you use.

You can read more about LibreOffice and The Document Foundation on their websites at
https://www.libreoffice.org/ and https://www.documentfoundation.org/.
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Minimum requirements

LibreOffice 7.0 requires one of the following operating systems:

* Microsoft Windows: Windows 7 SP1, Windows 8, Windows Server 2012, or Windows 10;
Administrator rights are needed for the installation process.

* GNU/Linux: Kernel version 3.10 or higher and glibc2 v2.17 or higher.

*  macOS 10.10 (Yosemite) or higher; however, support for macOS 10.10 and 10.11 is
deprecated.

Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java
Runtime Environment (JRE) (or, for macOS, the Java Development Kit (JDK)) is installed on your
computer. Although LibreOffice will work without Java support, some features will not be
available.

Java is available at no cost. More information and download links to the appropriate edition for
your operating system can be found at: https://java.com/en/download/manual.jsp
Note

If you want to use LibreOffice features that require Java, it is important that the
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the
Advanced Options in Chapter 2 of this guide.

For a more detailed listing of hardware and software requirements, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

How to get the software

Versions of LibreOffice for Windows, Linux, and macOS can be downloaded free from
https://www.libreoffice.org/download. You can also download the software by using a Peer-to-
Peer client, such as BitTorrent, at the same address.

Linux users will also find LibreOffice included in many of the latest Linux distributions; Ubuntu is
just one example.

macOS users can also get two versions of LibreOffice from the App Store for a small fee:
LibreOffice Vanilla and Collabora Office (an enterprise-ready version).

Windows users can also get LibreOffice Vanilla from the Microsoft Store for a small fee.

How to install the software

Information on installing and setting up LibreOffice on the various supported operating systems is
given here: https://www.libreoffice.org/get-help/install-howto/.

Extensions and add-ons

Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed
with the program and you can get others from the official extensions repository,
https://extensions.libreoffice.org/. See Chapter 14, Customizing LibreOffice, for more information
on installing extensions and add-ons.
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Starting LibreOffice

In general, you start LibreOffice the same way you start any other program on your computer.

On Windows and Linux, entries for LibreOffice and each of its components appear in the system
menu of your computer. On macOS, only an entry for LibreOffice is added to the Applications
menu. You can make a desktop icon for LibreOffice or a component in the same way you can
make a desktop icon for any other program; see your operating system’s help for how to do this.

Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center
(Figure 2) from where you can select the individual components of LibreOffice. You can also
choose to open an existing file or use a template. The thumbnails in the Start Center include an
icon showing the type of file (text, spreadsheet, drawing, presentation).

DOiLibreoffice

E Remote Files

@ Recent Files >

)

Templates -

o
@
&

Writer Document GS6401-IntroducingLibreOffice

Calc Spreadsheet

OLibreoffice
Impress Presentation
Draw Drawing

Math Formula

@ & B @ & [

Base Database

ebook-back CG6201-IntroducingCale

Figure 2: LibreOffice Start Center

Opening an existing document before starting LibreOffice

You can start LibreOffice by double-clicking the filename of an ODF document on the desktop, or
in a file manager such as Windows Explorer or macOS Finder. The appropriate component of
LibreOffice will start and the document will be loaded.

You can also open files stored in remote servers running Content Management Interoperability
Services (CMIS). CMIS, like OpenDocument Format, is an OASIS standard. When using CMIS
servers, the service will ask you for the necessary credentials for file access.

If you do not have Microsoft Office installed on your computer, or if Microsoft Office is installed
but you have associated Microsoft Office file types with LibreOffice, then when you double-click
on the following files, they open in LibreOffice:

* A Word file (*.doc or *.docx) opens in Writer.
* An Excel file (*.xIs or *.xIsx) opens in Calc.
* APowerPaint file (*.ppt or *.pptx) opens in Impress.

If you did not associate the file types and Microsoft Office is installed on your computer, then
when you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office
component.

For more information on opening files, see “Opening existing documents” on page 27.
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Parts of the main window

The main window is similar for each component of LibreOffice, although some details vary. See
the relevant chapters in this guide about Writer, Calc, Draw, Impress, Base, and Math for
descriptions of those details.

Common features include the Menu bar, standard toolbar, and formatting toolbar (Writer and Calc
only) at the top of the window and the status bar at the bottom.

Menu bar

The Menu bar is located across the top of the LibreOffice window, just below the title bar. When
you select one of the menus listed below, a sub-menu drops down to show commands. Below is
the case for Writer:

* File — commands that apply to the entire document such as Open, Save, and Export as
PDF.

* Edit — commands for editing the document such as Undo, Find & Replace, Cut, Copy,
Paste, and Track Changes.

» View — commands for controlling the display of the document such as Toolbars, Text
Boundaries, and Zoom.

* Insert — commands for inserting elements into your document such as Header, Footer,
and Image.

* Format — commands for formatting the layout of your document.

* Styles — commands for quickly applying common styles; for editing, loading, and creating
new styles; and for accessing the Styles deck in the Sidebar.

» Table — commands to insert and edit a table in a text document.

* Form — commands to create fill-in forms.

* Tools — functions such as Spelling, AutoCorrect, and Customize, and Options.

*  Window — commands for the display window.

* Help - links to the LibreOffice Help file, What's This?, and information about the program.

Toolbars

LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can
be moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the
Standard toolbar. It is consistent across the LibreOffice applications.

The second toolbar at the top for Writer and Calc, in a default LibreOffice installation, is the
Formatting bar. It is context-sensitive; that is, it shows the tools relevant to the current position of
the cursor or the object selected. For example, when the cursor is on a graphic, the Formatting
bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting
text.

In some cases it is convenient to reduce the number of toolbars displayed and get more space
for the document. LibreOffice provides a single-toolbar alternative to the default double-toolbar
setup. It contains the most-used commands. To activate it, enable View > User Interface >
Single Toolbar.

Other variations include Tabbed and Groupedbar Compact, both accessed from View > User
Interface. These provide a collection of tools at the top of the workspace, grouped in various
ways that may be familiar to users of Microsoft Office (the “ribbon”).

Chapter 1 Introducing LibreOffice | 21



Displaying or hiding toolbars
To display or hide toolbars in a standard setup, go to View > Toolbars on the Menu bar, then

click on the name of a toolbar from the submenu. An active toolbar shows a checkmark beside its
name. Toolbars created from tool palettes are not listed in the View menu.

To close a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Sub-menus and tool palettes

Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and
alternative methods of selecting items, depending on the icon.

Tool palettes can be made into a floating toolbar. Figure 3 shows an example of a tool palette
from the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating
toolbars” below for more information on moving and floating these toolbars created from tool
palettes.

Tool Palette Floating Toolbar
Basic Shapes * ¥
EDEQ;’U ——r T
Tettis sevsc
Abh 0000
EFPF+D0O

ESPFP+0O
®-® -E?%ﬁ\{:lick here and drag to create a

floating toolbar from a tool paletie.
Figure 3: Example of tearing off a tool palette

Moving toolbars

Docked toolbars can be undocked and moved to a new docked position or left as a floating
toolbar.

1) Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left
of a docked toolbar and highlighted in Figure 4.

2) Hold down the left mouse button and drag the toolbar to the new location. The toolbar can
be docked in a new position at the top, sides or bottom of the main window, or left as a
floating toolbar.

3) Release the mouse button.

To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the
toolbar at the top or bottom of the main window.

jle Edit View Insert F
A
B2y Ra

Default Style hd

Figure 4: Toolbar handles

Floating toolbars

LibreOffice includes several additional toolbars, whose default settings have them appear as
floating toolbars in response to the current position of the cursor or selection. You can dock these
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toolbars to the top or bottom of the main window, or reposition them on your computer display

(see “Moving toolbars” above).

Some of these additional toolbars are context sensitive and will automatically appear depending
on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears,
and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar. You can also add icons and create new toolbars, as
described in Chapter 14, Customizing LibreOffice. To access the customization options for a
toolbar, right-click in an empty space between the icons on a toolbar to open a context menu as

follows:

* To show or hide icons defined for the selected toolbar, point to Visible Buttons. Visible
icons on a toolbar are indicated by an outline around the icon (Figure 5) or by a check
mark beside the icon, depending on your operating system. Select or deselect icons to
hide or show them on the toolbar.
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Figure 5: Selection of visible toolbar icons
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* Click Customize Toolbar to open the Customize dialog; See Chapter 14, Customizing
LibreOffice, for more information.

* Click Dock Toolbar to dock the selected floating toolbar. You can reposition the toolbar to
a different docked position. See “Moving toolbars” on page 22.

» Click Dock All Toolbars to dock all floating toolbars. You can reposition the toolbars to
different docked positions. See “Moving toolbars” on page 22.

» Click Lock Toolbar Position to lock a docked toolbar into its docked position.

* Click Close Toolbar to close the selected toolbar.
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Context menus

Context menus provide quick access to many menu functions. They are opened by right-clicking
on a paragraph, graphic, or other object. When a context menu opens, the functions or options
available will depend on the object that has been selected. A context menu can be the easiest
way to reach a function, especially if you are not sure where the function is located in the menus
or toolbars. Context menus may display an applicable keyboard shortcut if one has been set; you
can toggle this visibility off or on in Tools > Options > LibreOffice > View > Visibility.

o gl.]l ae gl.lt Ctri+X
= Copy 4 Copy Ctri+C
| Paste Z] Paste Ctrl+V
Paste Special... Paste Special... Ctrl+Shift+V
Paste Only 4 Paste Only »
Clear Direct Formatting Clear Direct Formatting Ctrl+M
Format Cells... Format Cells... Ctrl+1
Insert.. Insert... Ctrl++
Delete... Delete... Ctri+-
@ Clear Contents... & Clear Contents.. Backspace
Insert Comment Insert Comment Ctrl+Alt+C

Figure 6: Keyboard shortcuts in context menus

Status bar

The status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to change some features quickly. It is similar in Writer, Calc,
Impress, and Draw, but each LibreOffice component includes some component-specific items. An
example of the Writer status bar is shown in Figure 7.

Page Word & character Insert Selection Document
number count Page style Language mode mode status
Page 3 of 6 (Page 1) 18 words, 71 characters Left Page English (Australia) Overwrite =]
B Outline Numbering : Level 2 [ . + | 100%
Digital Object View Zoom Zoom
signature information layout slider percent

Figure 7: Example status bar from Writer

Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or
slides in the document. Click on this field to open the Go to Page dialog. Other uses of this
field depend on the LibreOffice component.

Word & character count
Shows the total number of words and characters in the document or in the selection.

Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design,
double-click on this field. To choose a different page style or slide design, right-click on this
field and select from the list that pops up.

Language
Shows the current language of the text at the current cursor position.

24 | LibreOffice 7.0 Getting Started Guide



Insert mode
Shows the type of insert mode the program is in. This field is blank if the program is in
Insert mode. Each time the Ins key is pressed, or this field is clicked, the mode toggles
between Insert and Overwrite.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover
the mouse pointer over this field, a tooltip indicates which mode is active.

Unsaved changes
The icon shown here is different when changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can click the icon to
sign the document, or to view the existing certificate.

Object information
Displays information relevant to the position of the cursor or the selected element of the
document.

View layout
Select between Single-page view, Multiple-page view, and Book view to change how your
document is displayed.

Zoom slider
Drag the Zoom slider, or click on the + and — signs to change the view magnification of your
document.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to
open a list of magnification values from which to choose. Clicking on this percentage figure
opens the Zoom & View Layout dialog.

Sidebar

To activate the Sidebar, select View > Sidebar on the Menu bar. The Sidebar (Figure 8) is
located on the right side of the edit views of Writer, Calc, Impress, and Draw. It contains one or
more decks, based on the current document context. Decks are organized into panels. A tab bar
on the right side of the sidebar allows you to switch between different decks.

All four components contain the Properties, Styles, Gallery, and Navigator decks. Some
components have additional decks, such as Page for Writer; Master Slides, Animation, and Slide
Transition for Impress; Shapes for Draw; and Functions for Calc.

A panel is like a combination of a toolbar and a dialog. For example, you can freely mix working
in the main edit window to enter text and use the Properties panel in the sidebar to change text
attributes.

Toolbars and Sidebar panels share many functions. For example, the buttons for making text
bold or italic exist in both the Formatting toolbar and the Properties panel.

For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.

To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show
the Sidebar again.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the Sidebar
settings drop-down list at the top of the tab bar (see Figure 9). From the same list you can
choose which items to show in the Sidebar.
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Starting new documents

You can start a new, blank document in LibreOffice in several ways.

When LibreOffice is running but no document is open, the Start Center (Figure 2 on page 20) is
shown. Click one of the icons to open a new document of that type, or click the Templates icon

to start a new document using a template.

You can also start a new document in one of the following ways:

Use File > New on the Menu bar and select the type of document in the context menu.

Use the keyboard shortcut Ctr/+N to create a new document. The type of document
created depends on which LibreOffice component is open and active. For example, if
Calc is open and active, a new spreadsheet is created.
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* Use File > Wizards on the Menu bar and select the type of document in the context
menu.

* If adocument is already open in LibreOffice, click the New icon on the Standard toolbar
and a new document of the same type is created in a new window. For example, if Calc
is open and active, a new spreadsheet is created. The New icon changes depending on
which component of LibreOffice is open.

» If adocument is already open in LibreOffice, click on the small triangle to the right of the
New icon on the Standard toolbar and select the type of document from the context
menu that opens.

Note

If all documents are closed without exiting from LibreOffice, then the Start Center will
be displayed.

Opening existing documents

You can also open an existing document in one of the following ways:

* When no document is open, click Open File or Remote Files in the Start Center to reach
the corresponding open dialog.

* Goto File > Open or File > Open Remote on the Menu bar to reach the corresponding
open dialog.

* Use the keyboard shortcut Ctrl+O to reach the Open dialog.

» If adocument is already open, click the Open icon on the Standard toolbar and select
from a list of available documents from the Open dialog.

* Click the small triangle to the right of the Open icon and select from a list of recently
opened documents, click Open Template to select a template, or click Open Remote
File to open a remote file.

* When no document is open, click on a thumbnail of recently opened documents
displayed in the Start Center. You can scroll up or down in the Start Center to locate a
recently opened document.

When using the Open dialog, navigate to the folder you want, select the file you want, and then
click Open. If a document is already open in LibreOffice, the second document opens in a new
window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other
files that Calc opens.

You can also open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer.
LibreOffice has to be associated with file types that are not ODF files for the appropriate
LibreOffice component to open.

Note

When opening files stored in a remote server, you may be asked to enter your user
name and password to log in the server.
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Saving documents

You can save documents as follows:

* Save — use if you are keeping the document, its current filename and location.

* Save As — use to create a new document, or change the filename and/or file format, or
save the file in a different location on your computer.

* Save Remote — use if your document is already stored in a remote server or will be
stored in a remote server.

* Save a Copy — use to save a copy of your current document and keep it open for more
editing.

+ Save All — use to save all the files open in your current session.

Save command

To save a document if you are keeping the document’s current filename and location, do one of
the following:

* Use the menu option File > Save.

* Use the keyboard shortcut Ctrl+S.

* Click the Save icon on the Standard toolbar.

* Use the menu option File > Save All.

* Use the menu option File > Save Remote.

» Use the menu option File > Save a Copy (similar to the Save As command).
Using the Save command will immediately overwrite the last saved version of the file.

Save As command

@ Save As @
@uv| . v Dave » Temp » Test v |$,| Search Test 2 '
Organize * Mew folder 4== E@I

’ ifi v Siz
‘v Favorites Marme Date modified Type Size
@ Test.odt 24,03.2018 09:00  OpenDocument Text 15KB
B Desktop @ Your File 1.odt 01.04.201713:47  OpenDocument Text 11 KB
File name: G56001-Introducing_LibreQffice.odt -
Save as type: [ODF Text Document (odt) (*.odt) -

[#] Automatic file name
extension

[7] Save with password
[7] Encrypt with GPG key
Edit filter settings

~ Hide Folders [ Save ] [ Cancel l

;:igure 10: Example of LibreOffice Save As dialog

If you want to create a new document file, change the filename and/or file format, or save the file
in a different location on your computer:

* Use the keyboard shortcut Ctrl+Shift+S.
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Use the menu option File > Save As.

When the Save As dialog (Figure 10) or Save dialog opens, enter the file name, change the file
type (if applicable), navigate to a nhew location (if applicable), and click Save.

Password protection

To restrict who can open and read a document, or open and edit the document, use password
protection.

1)

Using the Save As command above, select the Save with password option in the Save
As dialog or Save dialog.

2) Click Save and the Set Password dialog opens (Figure 11).
3) In the File Encryption Password section, enter a password to open the document and
then enter the same password as confirmation.
4) To restrict who can edit the document, click Options.
5) In the File Sharing Password section, select Open file read-only, enter a password to
allow editing, and then enter the same password as confirmation.
6) Click OK and the dialog closes. If the passwords match, the document is saved
password-protected. If the passwords do not match, you receive an error message.
] Set Password A x
File Encryption Password
Enter password to open
Confirm password
MNote: After a password has been set, the document will only
open with the password. Should you lose the password,
there will be no way to recover the document. Please also
note that this password is case-sensitive.
= Qptions|
File Sharing Password
Open file read-only
Enter password to allow editing
Confirm password
| ok | Ccancel
Figure 11: Set Password dialog
Caution

LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if you lose or forget the password.

Changing the password

When a document is password-protected, you can change the password while the document is
open. Go to File > Properties > General on the Menu bar and click the Change Password
button. This opens the Set Password dialog where you can enter a new password.
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Saving documents automatically

LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving,
like manual saving, overwrites the last saved state of the file.

To set up automatic file saving:

1) Go to Tools > Options > Load/Save > General on the Menu bar.
2) Select Save AutoRecovery information every and set the time interval.
3) Click OK.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers. Keeping files on remote servers
allows you to work with the documents using different computers. For example, you can work on
a document in the office during the day and edit it at home for last-minute changes. Storing files
on a remote server also backs up documents from computer loss or hard disk failure. Some
servers are also able to check-in and check-out files, thus controlling their usage and access.

LibreOffice supports many document servers that use well known network protocols such as FTP,
WebDav, Windows share, and SSH. It also supports popular services like Google Drive and
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS
CMIS standard.

To enable a remote server connection, use one of these methods:

» Click on the Remote Files button in the Start Center.
* Select File > Open Remote in any open document.
* Select File > Save Remote in any open document.

On the Remote Files dialog (Figure 13), click Manage Services | Add Service button in the
upper right to open the File Services dialog (Figure 12). Depending on the type of file service you
choose in the Type listbox, different parameters are necessary to fully qualify the connection to
the remote server.

Ro File Services - 0%
Type: | Alfresco4 -
Host: http://<host:port=/alfresao/c

User: |

Password:

Remember password

Repository: v | 5
Label: Alfresco 4
Root:

Help Cancel

Figure 12: Remote server configuration

Once the connection is defined, click OK to connect. The dialog will dim until the connection is
established with the server. A dialog asking for the user name and the password may pop up to
let you log in the server. Proceed entering your credentials.
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The Remote Files dialog (Figure 13) which then appears has many parts. The upper list box
contains the list of remote servers you have previously defined. The line below the list box shows
the path to access the folder. On the left is the folder structure of the user space in the server.
The main pane displays the files in the remote folder. Click the Open or Save button to proceed.

=] Remote Files — O x
Service: | WebDAV: Nuvem v || Addservice | ¥

Root = remote.php = webdav =

= Root MName Size |Date modified
O ATIBAMK =]
3 Coworking [ san franciscojpg  211,0 KB 24/07/2015,22:19
3 documents [5] squirrel.jpg 228,2 KB 24/07/2015,22:19
[J Esmalteria
3 music
i)
3 Projeto
3 Shared

-

Filter All Files -

File mame paris.jpg

Help Cancel Open

Figure 13: Remote Files dialog when connected to a server

Using the Navigator

The LibreOffice Navigator lists objects contained within a document, collected into categories.
For example, in Writer it shows Headings, Tables, Frames, Comments, Images, Bookmarks, and
other items, as shown in Figure 14. In Calc it shows Sheets, Range names, Database ranges,
Images, Drawing objects, and other items. In Impress and Draw it shows Slides, Pages, and
other items.

To open the Navigator, press the F5 key, or go to View > Navigator on the Menu bar, or click the
Navigator icon on the Sidebar.

Click the marker (+ or triangle) by any of the categories to display the list of objects in that
category.

The Navigator provides several convenient ways to move around a document and find items in it:

* When a category is showing the list of objects in it, double-click on an object to jump
directly to that object’s location in the document.

* Objects are much easier to find if you have given them recognizable names when
creating them, instead of keeping the default names such as Sheetl, Tablel, or Table2.
The default names may not correspond to the actual position of the object in the
document.

» Navigator also provides the facility to move, promote, demote items within a document.

» Each Navigator in the individual LibreOffice components has a different range of
functions. These functions are further explained in the user guide for each LibreOffice
component.
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Figure 14: Navigator in Writer

Undoing and redoing changes

To undo the most recent unsaved change in a document, use the keyboard shortcut Ctrl+Z, or
click the Undo icon on the Standard toolbar, or go to Edit > Undo on the Menu bar. Click the
small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You
can select multiple changes and undo them at the same time.

After changes have been undone, you can redo changes. To redo a change use the keyboard
shortcut Ctri+Y, or click the Redo icon, or go to Edit > Redo on the Menu bar. As with Undo, click
on the triangle to the right of the Redo icon to get a list of the changes that can be reapplied.

To repeat the last command applied to your document, use the shortcut Ctr/+Shift+Y. This can
save several repetitive menu navigation clicks or keyboard shortcuts, especially when the
command is taken from a secondary menu.

Reloading a document

Reloading is useful in two situations.

* You may want to discard all the changes made in an editing session after the last
document save.

* You may have made some formatting changes that do not show until the document has
been closed and reopened; reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file
since the last save, a confirmation dialog will warn you that reloading will discard your last
changes. Choose whether to save or discard the changes.

On reloading the document, the File dialog does not open, because the file is already selected.

Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The
Properties dialog provides information about the document and allows you to set some of its
properties. The dialog and its tabs are described below.
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General

Contains basic information about the current file: file name and type; storage location; file size;
date, time, and author of file creation and last modification; template used to create the file; date,
time, and author of digital signature; date, time, and user name when the file was last printed;
total editing time; and revision number.

Controls available:
* Change Password — opens a dialog to change the password. It is only active if a
password has been set for the file.

» Digital Signatures — opens the Digital Signatures dialog where you can manage digital
signatures for the current document.

* Apply user data — saves the full name of the user with the file. You can edit the name by
going to Tools > Options > LibreOffice > User Data on the Menu bar.

* Save preview image with this document — saves a thumbnail.png inside the document.
These images may be used by a file manager under certain conditions.

* Reset Properties — resets the editing time to zero, the creation date to the current date
and time, and the version number to 1. The modification and printing dates are also
deleted.

Description

Contains optional editable descriptive information about the document, which may be exported
as metadata to other file formats.

* Title — enter a title for the document.

* Subject — enter a subject for the document. You can use a subject to group documents
with similar contents.

+ Keywords — enter the words that you want to use to index the content of the document.
Keywords must be separated by commas. A keyword can contain white space characters
or semicolons.

« Comments — enter comments to help identify the document.

Custom Properties

Use this page to assign custom information fields to the document. In a new document, this page
may be blank. If the new document is based on a template, this page may contain fields. You can
change the name, type, and contents of each row. The information in the fields will be exported
as metadata to other file formats.

Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties

Used for documents stored on remote servers; not shown otherwise. See the Help for more
information.

Security

Enables two password-protected security options.

* Open file read-only — select to allow this document to be opened only in read-only
mode. This file sharing option protects the document against accidental changes. It is still
possible to edit a copy of the document and save that copy with the same name as the
original.
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* Record changes — select to require that all changes be recorded. To protect the
recording state with a password, click Protect and enter a password. This is similar to
Edit > Track Changes > Record on the Menu bar. However, while other users of this
document can apply their changes, they cannot disable change recording without
knowing the password.

Protect or Unprotect button protects the change recording state with a password. If change
recording is protected for the current document, the button is named Unprotect. Click Unprotect
and type the correct password to disable the protection.

Font

When Embed fonts in the document is selected, any fonts used in the document will be
embedded into the document when it is saved. This may be useful if you are creating a PDF and
want to control how it will look on other computer systems.

Only embed fonts that are used in documents — If fonts have been defined for the document
(for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed — You can choose which types of fonts are embedded: Latin, Asian,
Complex.

Statistics

Displays statistics for the current file, such as the number of pages, words, and characters.

Closing a document

If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click on the X on the right or left end of the Menu bar. On Windows and Linux, the
document closes and the LibreOffice Start Center opens. On macOS, the document closes and
only the Menu bar remains at the top of the screen.

If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click on the X on the right or left end of the title bar of that document’s window.

If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.
Caution

Not saving your document could result in the loss of recently made changes, or
worse still, the entire file.

Closing LibreOffice

To close LibreOffice completely, go to File > Exit LibreOffice on the Menu bar in Windows and
Linux. In macOS, go to LibreOffice > Quit LibreOffice on the Menu bar.

In Windows and Linux, when you close the last document using the X on the title bar of the
window, then LibreOffice will close completely. In macOS, you need to use LibreOffice > Quit
LibreOffice.

You can also use a keyboard shortcut as follows:

* In Windows and Linux — Ctrl+Q
* In macOS — Command ¢£+Q
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If any documents have not been saved since the last change, a message box is displayed.
Choose whether to save or discard your changes.

Troubleshooting LibreOffice in Safe Mode

You can use Safe Mode to help restore an instance of LibreOffice that has become corrupted and
stopped working or fails to launch.

To access Safe Mode, do one of the following:
* Choose Help > Restart in Safe Mode on the Menu bar.
» Start LibreOffice from the command line with the - -safe-mode option.
* In Windows only, choose LibreOffice (Safe Mode) from the Start Menu.

#® Safe Mode

LibreOfficeDev is now running in safe mode which temporarily disables your user configuration and extensions.
You can make one or more of the following changes to your user profile to return LibreOFfficeDev to a working state.

The proposed changes get more radical from top down so it is recommended to try them successively one after another.

Restore user configuration to the last known working state
| Restore state of installed user extensions to the last known working state

) Configure

Disable all user extensions

Disable hardware acceleration (OpenGL, OpencCL)
) Extensions

Uninstall all user extensions

Reset state of shared extensions

Reset state of bundled extensions
) Reset to Factory settings

Reset settings and user interface modifications

Reset entire user profile

»  Advanced

Help | Continuein Safe Mode | Restart in Normal Mode Apply Changes and Restart

Figure 15: LibreOffice Safe Mode

The following Safe Mode options get more extreme from the top down, so it is recommended that
you try them successively.

* Restore from backup — LibreOffice keeps backups of previous configurations and
activated extensions. Use this option to restore the user configuration, installed
extensions, or both, to a previous known working state if you suspect that your problems
were caused by recent changes to either.

* Configure — Use this option to disable all user extensions, hardware acceleration, or
both. This is a good choice if you are experiencing crashes on startup or visual glitches
that are often related to hardware acceleration.

» Extensions — If you suspect that a corrupted extension is blocking or causing LibreOffice
to crash, you can use this option to uninstall all user extensions and reset the state of
any shared or bundled extensions. In the case of shared or bundled extensions, the
option will only work if you have the proper system access rights. It should be exercised
with caution.

* Reset to factory settings — If all of the above fails, you can reset your settings and your
user interface modifications, or your entire profile back to factory defaults.
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— Reset settings and user interface modifications — this will reset your User Interface
and configuration changes, but keep things like your personal dictionary, templates,
etc.

— Reset entire user profile — this will erase all customized options and return your user
profile to the factory default state.

* Continue in Safe Mode — Continuing in Safe Mode will allow you to work in LibreOffice,
using a temporary profile that was created on startup. Any extensions or configuration
options you had set up previously will have to be reconfigured in order to be used,
bearing in mind that any changes made to the temporary user profile will be lost after any
restart.

* Restart in Normal Mode - If you arrived in Safe Mode accidentally, this option will
discard any changes, terminate Safe Mode, and restart LibreOffice normally.

* Apply Changes and Restart — Choose this option to apply any of the above changes
and restart LibreOffice.

Note

If you are unable to solve your problem using Safe Mode, the Advanced tab provides
instructions on receiving further aid.

In the Advanced tab you can also create a .zip file of your corrupted user profile
which can then be uploaded to the bug tracking system where it can be further
investigated by the developers.

However, be aware that your uploaded user profile may contain sensitive information
such as installed extensions, personal dictionaries, and settings.
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Introduction

This chapter briefly presents some of the setup options found under Tools > Options on the
Menu bar (LibreOffice > Preferences on macOS). Additional options, and more details about
the ones given here, are covered in the Help.

O Tip
Many options are intended for power users and programmers. If you don’t

understand what an option does, it's usually best to leave it on the default setting
unless instructions in this book recommend changing the setting.

Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the Help.

Click Tools > Options (LibreOffice > Preferences on macOS). The list in the left-hand box of
the Options — LibreOffice dialog varies depending on which component of LibreOffice is open.
The illustrations in this chapter show the list as it appears when a Writer document is open. If you
are using a version of LibreOffice other than US English, some field labels may be different from
those shown in the illustrations.

Click the expansion symbol (+ or triangle) next to LibreOffice. A list of subsections drops down.
Select an item in the list to display the relevant page on the right-hand side of the dialog.

Options - LibreOffice - Paths

=l LibreQffice
User Data
General
View
Print
| Paths
Fonts
Security
Personalization
Application Colors
Accessibility
Advanced
Online Update
OpenCL
Load/Save
Language Settings
LibreQffice Writer

+  LibreOffice Writer/Web
Tl ihrafffire Dace

Figure 16: LibreOffice options

H F F

Note

The Reset button, located in the lower right of the Options dialog, resets the values
on that page to the values that were in place when you opened the dialog. It may be
called Revert on some installations.
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User data

Because LibreOffice can use the name or initials stored in the LibreOffice — User Data page for
several things — including document properties (“created by” and “last edited by” information), the
name of the author of comments and changes, and the sender address in mailing lists — you will
want to ensure that the correct information appears here.

Fill in the form, or amend or delete any existing information. If you do not want user data to be
part of the document’s properties, deselect Use data for document properties.

Address
Company:
First/last name/initials: Colleen Hayes CH
Street:
City/state/zip:
Country/region:
Title/position:

Telephone (home/work):

Fax/email:
Use data for document properties
Cryptography
CpenPGP signing key: Mo key ~
OpenPGP encryption key: Mo key ~

When encrypting documents, always encrypt to self
Figure 17: User Data page

In the Cryptography section, you can set the preferred public key for OpenPGP encryption and
digital signature. These preferred keys will be pre-selected in the key selection dialog when you
sign or encrypt a document (see Chapter 10, Printing, Exporting, Emailing, and Signing
Documents).

General
The options on the LibreOffice — General page (Figure 18) are described below.

Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.

Help - Show “No offline help installed” popup
Deselect to disable this popup dialog when you select Help, if offline help is not installed.

Help - Show “Tip of the Day” dialog on start-up
Deselect to disable the “Tip of the Day” dialog. You can also disable this from the dialog.

Openi/Save Dialogs — Use LibreOffice dialogs
Select this option to use the Open and Save dialogs supplied with LibreOffice. Deselect to
use the standard Open and Save dialogs of your operating system. This guide uses the
LibreOffice Open and Save dialogs in illustrations.

Document Status - Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print
date is recorded in the document properties as a change and you will be prompted to save
the document again, even if you did not make any other changes.
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Help

[] Extended tips
Show "Mo offline help installed" popup
[ Show “Tip of the Day" dialog on start-up

Open/5ave Dialogs
[ Use LibreOffice dialogs

Document Status
] Printing sets "document modified” status

Year (Two Digits)
Interpret as years between (1930 2| and 2029

Help Improve LibreOffice

[ Collect usage data and send it to The Document Foundation
Send crash reports to The Document Foundation

LibreQffice Quickstarter
[ Load LibreOffice during system start-up

LibreOffice File Associations
Windows Default apps

Figure 18: Setting general options for LibreOffice

Year (Two Digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.

Help Improve LibreOffice — Collect usage data and send it to The Document Foundation
Send usage data to help The Document Foundation improve usability of the software. The
usage data is sent anonymously and carries no document contents, only the commands
used.

Help Improve LibreOffice — Send crash reports to The Document Foundation
(Windows only.) If this option is selected, the Error Report Tool starts automatically when a
program crash occurs. The tool gathers all necessary information that can help the program
developers to improve the code. You can include some additional information that may help
the developers to localize the error. For more information, see the Help.

LibreOffice Quickstarter — Load LibreOffice during system start-up
When this option is selected, the necessary library files are loaded when the computer is
started, resulting in a shorter startup time for LibreOffice components. The old menu in the
system tray is no longer used. Not available on macOS.

LibreOffice File Associations — Windows Default apps button
(Windows only.) Behavior varies: opens Default apps dialog on Windows 7, 8, 8.1; displays
a message on Windows 10 telling user how to open Default apps manually.
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View

The options on the LibreOffice — View page affect how the document window looks and behaves.
Some of these options are described below Figure 19. Set them to suit your personal
preferences. Some of the available options vary with your computer’s operating system; the
figure shows the options on Windows 10.

lcon style Graphics Qutput
lcon style: Automatic (Colibre) w 2ZEENL =R e HEnal
lUse anti-aliasing
lcon size se Skia for all rendering
Toolbar: Automatic V [] Force Skia software rendering
) Skia is currently enabled.
Motebookbar  |Automatic e
Sidebar: Automatic w Font Lists
Show preview of fonts
Visibility Screen font antialiasing
Menu icons:  |Automatic w from: |8 pixels -
Shortcuts: Automatic w
Mouse
Positicning: Mo automatic positioning |~
Middle button: |Automatic scrolling w

Figure 19: Choosing View options for LibreOffice applications

Icon style
This box specifies the icon style used in toolbars and dialogs. The Automatic option uses
an icon set compatible with your operating system and choice of desktop. Several icon sets
are available: Breeze, Breeze Dark, Colibre, Elementary, Karasa Jaga, Sifr, Sifr Dark, and
Sakapura. You can add other icon sets using extensions; see Chapter 14, Customizing
LibreOffice.

Icon size - Toolbar, Notebookbar, Sidebar
Choose the display size of toolbar icons (Automatic, Small, Large, Extra Large (only for
toolbar)). The Automatic icon size option uses the setting for your operating system. The
toolbars, sidebar, and notebookbar (tabbed, grouped, and contextual versions) can have
different settings.

Visibility - Menu icons, Shortcuts
You can choose to hide or show icons as well as text on Menu bar and context menu items.

Mouse - Positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Mouse - Middle button
Defines the function of the middle mouse button (if present).
* Automatic scrolling — dragging while pressing the middle mouse button shifts the view.

» Paste clipboard — pressing the middle mouse button inserts the contents of the
Selection clipboard at the cursor position.

The Selection clipboard is independent of the normal clipboard that you use by Edit >
Copyl/Cut/Paste. Clipboard and Selection clipboard can contain different contents at the
same time.
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Function Clipboard Selection clipboard

Copy content Edit > Copy Ctr/+C Select text, table, or object.

Paste content Edit > Paste Ctr/+V pastes at Clicking the middle mouse button pastes
the cursor position. at the mouse pointer position.

Pasting into another No effect on the clipboard The last marked selection is the content

document contents. of the Selection clipboard.

Graphics Output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.

Graphics Output — Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

OTip

Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.

Graphics Output — Use Skia for all rendering
Enables and disables the use of the 3D graphics language Skia. Not supported on all
operating systems and LibreOffice distributions.

Graphics Output — Force Skia software rendering
Forces the use of Skia even if the graphics device is blacklisted. A device is blacklisted
when it is buggy or may render graphics with poor quality. Not supported on all operating
systems and LibreOffice distributions.

Font Lists — Show preview of fonts
Causes the font list to look like Figure 20, Left, with the font names shown as an example
of the font; with the option deselected, the font list shows only the font names, not their
formatting (Figure 20, Right). The fonts you will see listed are those that are installed on
your system. Fonts which are tuned for use with a specific script, such as Arabic, Hebrew,
Malayalam, and so on, show an additional preview of some sample text in the target script.

Font lists — Screen font anti-aliasing
(Not available in Windows.) Select this option to smooth the screen appearance of text.
Enter the smallest font size to apply anti-aliasing.

(2 - BT U-= M & | [7][z [-|B 7 U

Liberation Serif
Linux Biolinum G

Linux Biolinum G Linux Libertine Display G
. . . . Linux Libertine G
Linux Libertine Display G LKLUG
Linux Libertine G Loma
1 ]
LKLUG BEW & ;’“C mry_KacstQurn
o NanumBarunGothic
Lohit Punjabi H_TEIH&T NanumGothic
» NanumMyeongjo
Loma i]ﬂ‘l.'l'ﬁul‘lﬂﬂ Nimbus Mono L
mrv Kacstourn - - F Nimbus Roman No9 L
Y- Q A5 A Nimbus Sans L

NanumBarunGothic 32 Norasi
Figure 20: Font list (Left) with preview; (Right) without preview
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Print

On the LibreOffice — Print page (Figure 21), you can set the print options to suit your default
printer and your most common printing method. Most of these options should be self-explanatory.

Settings for

(@) Printer

() Print to file
Defaults Warnings

[ convert colors to grayscale O Paper size

nclude transparent objects DPapgrorientation
Transparency

Reduce Bitmaps Reduce Gradient

[J Reduce kitmaps [J Reduce gradient

T
4

Reduce Transparency
[] Reduce transparency

Figure 21: Choosing general printing options for all components

In the Warnings section, you can choose whether to be warned if the paper size or orientation
specified in your document does not match the paper size or orientation available for your printer.
Having these warnings turned on can be quite helpful, particularly if you work with documents
produced by people in other countries where the standard paper size is different from yours.

@ Tip
If your printouts are incorrectly placed on the page or chopped off at the top, bottom,

or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.

Note

Linux installations have an extra option (not shown in Figure 21): PDF as Standard
Print Job Format. Select this option to change the internal print job format from a
Postscript document description to a PDF description. This format has a number of
advantages over Postscript. For more information, see
https://www.linuxfoundation.org/collaborate/workgroups/openprinting/

pdf _as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

Paths

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. For example, you might want to store documents by
default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 22 and click Edit. On the Select
Paths dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and
then click OK to return to the Options dialog.
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Some items can have at least two paths listed: the User Path is to a user-specific folder (normally
on the user’s personal computer) and the Internal Path is to a shared folder where LibreOffice is
installed (which might be on a network).

OTip

You can use the entries on the LibreOffice — Paths page to compile a list of files,
such as those containing AutoText, that you need to back up or copy to another
computer.

Paths used by LibreQffice

Type |U5er Paths Internal Paths

AutoCorrect ChlsershJean\AppDatatReaminghLibreOffice\d  CAProgram Files\LibreOfficelprogran.\share\autocorr
AutoText ChlsershJean\AppDatatReaminghLibreOffice\d  CAProgram Files\LibreOfficel program.\sharehautotexthen-
Backups ChlUsers\Jean\AppDatatReamingLibreOffice\ 4

Dicticnaries ChlUsershJean\AppDatatReamingiLibreOffice\dy  CAProgram Files\LibreOfficel programb. \share\wordbock
Gallery ChlUsersh\Jean\AppDatatReaming\LibreOffice\dy  C\Program Files\LibreOfficelprogramb..\share\.gallery
Images ChUsershJean\AppData\Roaming'\ LibreOfficeld

Termporary files  ChUsers\Jean\AppDatatLocal\Temp

Templates ChlUsers\Jean\AppDatatRoarmingi LibreOffice\dy  CA\Program Files\LibreOffice\ program.\share\templatel.con

My Documents  ChlUsers\Jean\Documents

Classification Ch\Program Files\LibreOffice\programt..\shareic

Default Edit...

Figure 22: Viewing the paths of files used by LibreOffice

Fonts

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system,
LibreOffice will substitute fonts for those it does not find. You might prefer to specify a different
font from the one that the program chooses.

Note

These choices do not affect the default font for your documents. To do that, you need
to change the default template for documents, as described in Chapter 3, Using
Styles and Templates.

On the LibreOffice — Fonts page (Figure 23):

1) Select the Apply replacement table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to
type itin.)

3) Inthe Replace with box, select a suitable font from the drop-down list of fonts installed
on your computer.
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4) Click on the tick (check) icon to the right of the Replace with box. A row of information
now appears in the larger box below the input boxes. Select Always to replace the font,
even if the original font is installed on your system. Select Screen only to replace the
screen font only and never replace the font for printing. The results of combining these
selections are given in Table 1.

5) In the bottom section of the page, you can change the typeface and size of the font used
to display source code such as HTML and Basic (in macros).

Replacement Table
Font: Replace with:
Comic Sans M5 ~ | |Anal -
Always Screen only  (Font Replace with

|| Comic Sans M5

Apply replacement tablel

Font Settings for HTML, Basic and SQL Sources

Fonts: |Aut|:|matic ~

Mon-proportional fonts only

Figure 23: Defining a font to be substituted for another font
Table 1. Font substitution replacement actions

Always Screen only Replacement action

checkbox checkbox

checked blank Font replaced on screen and when printing, whether the font is installed

or not.

checked checked Font replaced only on screen, whether the font is installed or not.

blank checked Font replaced only on screen, but only if font is not available.

blank blank Font replaced on screen and when printing, but only if font is not available.
Security

Use the LibreOffice — Security page (Figure 24) to choose security options for saving documents
and for opening documents that contain macros.

Security Options and Warnings
If you record changes, save multiple versions, or include hidden information or notes in
your documents, and you do not want some of the recipients to see that information, you
can set warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file
whether the file is in LibreOffice’s default OpenDocument format, or has been saved to
other formats, including PDF.
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Click the Options button to open a separate dialog with specific choices (Figure 25). See
“Security options and warnings” on page 47.

Security Options and Warnings

Adjust security related options and define warnings for

hidden information in documents, Bl

Passwords for Web Connections

L] Persistently save passwords for web connections Lonnections

Macro Security

Adjust the security level for executing macros and specify

Macro Security...
trusted macro developers, W

TSAs

Maintain a list of Time Stamping Authority (TSA) URLs to be
used for digital signatures in PDF export.

T5As...

Figure 24: Choosing security options for opening and saving documents

Passwords for web connections
You can enter a master password to enable easy access to websites that require a user
name and password. LibreOffice will securely store all passwords that you use to access
files from web servers. You can retrieve the passwords from the list after you enter the
master password.

Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here),
where you can adjust the security level for executing macros and specify trusted sources.

Certificate Path
Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However,
a personal certificate issued by an outside agency (after verifying an individual’s identity)
has a higher degree of trust associated with it than does a self-signed certificate.
LibreOffice does not provide a secure method of storing these certificates, but it can access
certificates that have been saved using other programs. Click the Certificate button and
select which certificate store to use. Not available on Windows; LibreOffice uses the default
Windows location for storing and retrieving certificates.

TSAs -Time Stamping Authorities
You can optionally select a Time Stamping Authority (TSA) URL for PDF documents
created by LibreOffice. Recipients of PDF documents with a trusted timestamp can verify
when the document was digitally or electronically signed, as well as verify that the
document was not altered after the date the timestamp vouches for.
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Security options and warnings
Most of the options on the Security Options and Warnings dialog (Figure 25) should be self-
explanatory.

Security Options and Warnings *

Security Warnings
Warn if document contains recorded changes, versions, hidden information or notes:
LIaWhen saving or sending When signing
(] When printing (] When creating PDF files

Security Options
[] Remove personal information on saving
[] Recommend password protection on saving
Ctrl-click required to open hyperlinks

[ Block any links from docurments not among the trusted locations (see Macro Security)

Help QK Cancel

Figure 25: Security Options and Warnings dialog

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file.
To manually remove personal information from specific documents, deselect this option.

Ctrl+click required to open hyperlinks
The default behavior to open a hyperlink in LibreOffice is to Ctri+click on the hyperlink.
Many people find creation and editing of documents easier when accidental clicks on links
do not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click,

deselect this option.

Personalization
You can customize the overall appearance of LibreOffice with themes.

On the LibreOffice — Personalization page, select Preinstalled Theme and then click on a theme
thumbnail and click Apply. After a brief pause the appearance of LibreOffice will refresh and
reflect the selected theme.

LibreOffice Themes

(®) Default look, do not use Themes:

O Preinstalled Theme

Figure 26: Selecting a preinstalled theme
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Application colors

Writing, editing, and page layout are often easier when you can see the page margins (text
boundaries), the boundaries of tables and sections (in Writer documents), page breaks in Calc,
grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that are
different from LibreOffice’s defaults for such items as comment indicators or field shadings.

On the LibreOffice — Application Colors page (Figure 27), you can specify which items are visible
and the colors used to display various items.

« To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

* To change the default colors for items, click the down-arrow in the Color setting column
by the name of the item and select a color from the list box. Note that you can change
the list of available colors by selecting other available palettes from the drop-down list.

» To save your color changes as a color scheme, click Save, type a name in the Name of
color scheme box in the popup dialog (not shown), and then click OK.

Color Scheme
Scheme:  |LibreQffice ~ Save Delete
Custom Colors
On  User interface elerments Color setting
General "
Document background [ | Automatic b
[ Text boundaries |:|Autu:umatic b
Application background [ | Automatic v
Object boundaries [ ] Automatic v
[] Table boundaries I:l.\'lutamatic b
Font color - Butomatic b
[ Unvisited links - Butomatic b
Tl b Tl B i - ¥

Figure 27: Showing or hiding text, object, and table boundaries

Accessibility

Accessibility options include whether to allow animated graphics or text, some options for high
contrast display, and a way to change the font for the LibreOffice user interface.

Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and
information.

Select or deselect the options on the LibreOffice — Accessibility page (Figure 28) as required.
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Miscellaneous Options
[l Support assistive technology tools (program restart required)
[] Use text selection cursor in read-only text documents
[ Allow animated images
Allow animated text

Options for High Contrast Appearance
[ Automatically detect high contrast mode of operating system
[] Use automatic font color for screen display

Use system colors for page previews

Figure 28: Choosing accessibility options

Advanced

LibreOffice needs Java to run several wizards, the Mediawiki Publisher (if available; see page
60), and some functions in the Base component.

Java Options

Use a Java runtime envircnment

Java runtime environments (JRE) already installed:

Add..

Parameters...

Class Path...

Location: C\Program Files\Java\jre1.8.0_231

Optional Features
] Enable experimental features (may be unstahble)

L] Enable macro recording (may be limited)

Open Expert Configuration

Figure 29: Choosing a Java runtime environment

Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if
you have more than one JRE installed on your computer, you can use the LibreOffice —
Advanced options page to choose the JRE for LibreOffice to use.

If LibreOffice finds one or more JREs on your computer, it will display them in the large box.
You can then choose one of the JREs listed.

If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path dialogs (reached using the
buttons on the right) to specify this information.
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Optional Features

Enable experimental features (may be unstable)
Select this option to enable features that are not yet complete or contain known bugs. The
list of these features is different version by version.

Enable macro recording (may be limited)
This option enables macro recording, with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began,
are not supported. Only actions relating to document contents are recordable, so changes
in options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.

Open Expert Configuration
Most users will have no need to use this. Click this button to open a new dialog in which
you can fine-tune the LibreOffice installation. The dialog offers detailed configuration
options for many aspects of LibreOffice’s appearance and performance. Double-click on a
listed preference to enter a value to configure the preference.

Caution

The Expert Configuration dialog lets you access, edit, and save configuration
preferences that can turn the user profile of LibreOffice unstable, inconsistent, or
even unusable. If you do not know what an option does, you can best leave it as the
default.

Online update

On the LibreOffice — Online Update page (Figure 30), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can download the update.

If the Download updates automatically option is selected, the download starts when you click
the icon. To change the download destination, click the Change button and select the required
folder in the file browser window.

If the Send OS version and basic hardware information option is selected, information about
the computer architecture and operating system will be sent to the server for statistics collection.

Online Update Options
Check for updates automatically
i) Every day
(®) Every week
i) Every month

Last checked: 01/10/21, 09:51:00 AM Check Mow

Download Destination
] Download updates automatically

Download destination: Cih\Users\colle\Downloads Change...

User Agent
O Send O5 version and basic hardware information

User Agent: LibreOffice 7.0.4.2
(dcfl40e67528d0187c66b2370df 5ead 407420775,
Windows:

WOE SA.

Figure 30: Online update options

50 | LibreOffice 7.0 Getting Started Guide



OpenCL

OpenCL (Open Computing Language) is a software architecture used to write programs that run
in different processors of the computer, such as the CPU and GPU (graphics processing unit) of
the video card. With OpenCL enabled, LibreOffice can benefit from the very fast numerical
calculations performed in the GPU, which is especially useful in very large spreadsheets with
extensive calculations. The computer video card driver must have support for OpenCL to use this
feature.

Choosing options for loading and saving documents

You can set the options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General
Most of the choices on the Load/Save — General page (Figure 31) are familiar to users of other
office suites. Some items of interest are described below.

Load
Load user-specific settings with the document
Load printer settings with the decument
Save
Save AutoRecovery information every: |10 = minutes
[ Edit document properties before saving
0l Always create backup copy
Save URLs relative to file system
Save URLs relative to internet

Default File Format and ODF Settings

QODF format version: |‘I .3 Extended (recommended) w |
Document type: |TE:(t document w |
Always save as: |DDF Text Document (*.odt) w |

Warn when not =aving in ODF or default format
Figure 31: Choosing Load and Save options

Load user-specific settings with the document
A LibreOffice document contains settings that are read from the user’s system. When you
save a document, these settings are saved with it. Select this option so that when a
document loads, it ignores the stored settings in favor of the settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice
installation:

* Print settings

* Name of Fax

* Spacing options for paragraphs before text tables

* Information about automatic updating for links, field functions and charts
* Information about working with Asian character formats.
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The following setting is always loaded with a document, whether or not this option is
marked:

¢ Data source linked to the document and its view

If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings with the document option.

Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a
document to be printed on a distant printer (perhaps in an office setting), if you do not
change the printer manually in the Print dialog. If disabled, your default printer will be used
to print this document. The current printer settings will be stored with the document whether
or not this option is selected.

Save AutoRecovery information every __ minutes
Choose whether to enable AutoRecovery and how often to save the information used by
the AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to
restore all open documents in case of a crash. If you have this option set, recovering your
document after a system crash will be easier.

Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save
As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a
document. Every time LibreOffice creates a backup copy, the previous backup copy is
replaced. The backup copy gets the extension BAK. Authors whose work may be very
lengthy should always consider using this option.

Save URLs relative to file system | internet
Use these options to select the default for relative addressing of URLSs in the file system
and on the Internet. Relative addressing is only possible if the source document and the
referenced document are both on the same drive.

Arelative address always starts from the directory in which the current document is
located. In contrast, absolute addressing always starts from a root directory. The following
table demonstrates the difference in syntax between relative and absolute referencing.

Examples File system Internet
relative ../limages/img.jpg ..[images/img.jpg
absolute file:///c|/work/images/img.jpg http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in
your document will be saved relative to the location in the file system. In this case, it does
not matter where the referenced directory structure is recorded. The files will be found
regardless of location, as long as the reference remains on the same drive or volume. This
is important if you want to make the document available to other computers that may have
a completely different directory structure, drive or volume names. It is also recommended to
save relatively if you want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the
document containing the references can be moved to other directories or folders, and the
references remain valid.
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Default File Format and ODF Settings

ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.3 Extended, unless the user has previously changed the version in the
configuration. While this allows for improved functionality, there may be backwards
compatibility issues. When a file saved in ODF 1.3 Extended is opened in an editor that
uses an earlier version of ODF, some of the advanced features may be lost. If you plan to
share documents with people who use editors that use older versions of ODF (such as
Apache OpenOffice or LibreOffice 3.x), you may wish to save the document using ODF 1.2
Extended (compatibility mode).

Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to the Microsoft Office formats.
Current versions of Microsoft Word can open ODT files, so this may no longer be needed.

VBA properties

On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice.

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect
it with the Basic IDE you will notice that it is all commented), with this option the code is ready to
be executed.

Microsoft Word

Load Basic code
Executable code
Save original Basic code

Microsoft Excel
Load Basic code
Executable code
Save original Basic code

Microsoft PowerPoint

Load Basic code
Save original Basic code

Figure 32: Choosing Load/Save VBA Properties

Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved
when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save
original Basic code. The document will be saved without the Microsoft Basic code.
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Microsoft Office

On the Load/Save — Microsoft Office page (Figure 33), you can choose what to do when
importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents
such as spreadsheets or equations).

The Embedded Objects section specifies how to import and export Microsoft Office OLE objects.
These settings are valid when no Microsoft OLE server exists (for example, in UNIX) or when
there is no LibreOffice OLE server ready for editing the OLE objects. If an OLE server is active
for the embedded object, then the OLE server will be used to handle the object.

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”). Linux
installations may include selectable [S] options not shown in the illustration for the last three
items.

Embedded Objects

| 151

MathType to LibreOffice Math or reverse
WinWord to LibreOffice Writer or reverse
Excel to LibreOffice Calc or reverse

K EEE]

PowerPoint to LibreOffice Impress or reverse
SrartArt te LibreOffice shapes or reverse
Wisio to LibreOffice Draw or reverse

REORREE

PDF to LibreQOffice Draw or reverse

[L]: Load and convert the object  [5]: Convert and save the object

Character Highlighting Lock files
Export as: O Highlighting O Shading [ Create MSO lock file

Figure 33: Choosing Load/Save Microsoft Office options

Character Highlighting — Export as
Microsoft Office has two character attributes similar to LibreOffice character background.
Select the appropriate attribute (Highlighting or Shading) which you would like to use during
export to Microsoft Office file formats.

Lock files — Create MSO lock file
LibreOffice can report which Microsoft Office user has locked a document by reading the
lock files generated by MSO; and when the Create MSO lock file option is selected,
LibreOffice will generate such files in addition to its own lock files, so MSO users can know
who has locked a document.
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HTML compatibility

Choices made on the Load/Save — HTML Compatibility page (Figure 34) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents;
importing/exporting in the Help for more information.

Font Sizes Import
Sizel: |7 = [] Use 'English (USA)' locale for numbers
U Import unknown HTML tags as fields

Sized: (10 =
[] Ignore font settings

Sized (12 =
Export
Szed M4 51 [Oiibreoffice Basic
Sized: |18 = Display warning
Size f: |24 2 L1 Print layout
= Copy local images to Internet
Size 7: |36 =

Character set:  (Western Europe (Windows-1252/WinlLatin 1) |~

Figure 34: Choosing HTML compatibility options

Font Sizes
Use these fields to define the respective font sizes for the HTML <font size="1"> to <font
size="7"> tags, if they are used in the HTML pages. (Many pages no longer use these
tags.)

Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however,
contains no information about the locale. If this option is not selected, numbers will be
interpreted according to the Locale setting in Tools > Options > Language Settings >
Languages (see page 56). If this option is selected, numbers will be interpreted as for the
English (USA) locale.

Import — Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag
name. For a closing tag, an HTML_OFF will be created. These fields will be converted to
tags in the HTML export.

Import - Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML page style will be used.

Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML
format. You must activate this option before you create the LibreOffice Basic macro;
otherwise the script will not be inserted. LibreOffice Basic macros must be located in the
header of the HTML document. Once you have created the macro in the LibreOffice Basic
IDE, it appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose
Tools > Customize > Events. See Chapter 13, Getting Started with Macros, for more
information.

Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning
option becomes available. If the Display warning option is selected, then when exporting
to HTML a warning is shown that LibreOffice Basic macros will be lost.
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Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These
capabilities are only effective if print layout export is activated.

Export — Copy local images to Internet
Select this option to automatically upload the embedded pictures to the Internet server
when uploading using FTP.

Export — Character set
Select the appropriate character set for the export.

Choosing language settings

To customize the language settings in LibreOffice, you can do any of the following:

* Install the required dictionaries
* Change some locale and language settings
* Choose spelling options

Install the required dictionaries

LibreOffice automatically installs many dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then choose Tools > Language > More
Dictionaries Online. LibreOffice will open your default web browser to a page containing links to
additional dictionaries that you can install. Follow the prompts to select and install the ones you
want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.

In the Options dialog, click the expansion symbol (+ or triangle) by Language Settings. The
exact list shown depends on the language support settings (see Figure 36).

+ LibreCffice 1 LibreOffice
+  Load/Save +  Load/Save
= Language Settings i ngs
{ anquages: ;
Writing Aids Writing Aids
English sentence checking Searching in Japanese
* LibreCffice Writer Agian Layout
4 LibreOffice Writer Web Complex Text Layout
+ LibreCffice Base English sentence checking
+ Charts + LibreOffice Writer
+  Internet + LibreOffice WriterfWeb
+ LibreOffice Base
1 Charts
+ - Internet

Figure 35: LibreOffice language options, without and with Asian and
CTL options enabled

On the right-hand side of the Language Settings — Languages page (Figure 36), change the User
interface, Locale setting, Default currency, and Default Languages for Documents as required. In
the example, English (USA) has been chosen for all the appropriate settings.
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Language OFf

User interface: Default - English (USA) o
Formats

Locale setting: Default - English (USA) ~

Default currency: Default - USD ~

Decimal separator key: [] same as locale setting (. )

Date acceptance patterns: | M/DYY;M/D

Default Languages for Documents
Western: ab. Default - English (USA) ~
[ asian: [Mone]
O Complex text layout: [Mone]
[ Far the current document only

Enhanced Language Support
[] Ignere system input language

Figure 36: Choosing language options

User interface
The language of the user interface is usually set at the time LibreOffice is installed to match
the language of the operating system. If more than one language has been installed for
LibreOffice, you can select which language will be used for menus, dialogs, and help files.

Locale setting
The locale setting is the basis for many other settings within LibreOffice, for example
defaults for numbering, currency, and units of measure. Unless you select something else
here, the locale of the operating system will be set as default.

Default currency
The default currency is that used in the country entered as locale. The default currency
determines the proper formatting of fields formatted as currency. If the locale setting is
changed, the default currency changes automatically. If the default currency is changed, all
dialogs involving currency and all currency icons will be changed in all open documents.
Documents that were saved with one currency as the default will open using the new
currency defaults.

Decimal separator key
If the Decimal separator key — Same as locale setting option is selected, LibreOffice uses
the character defined by the default locale. If this option is not selected, the keyboard driver
defines the character used.

Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also
defines the default expression of dates. You can define additional date patterns, separated
by semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly
interpret dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.

Caution

Data entered into a Calc spreadsheet or a Writer table must be entered in a format
defined by locale in order to be recognized as dates.
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Default Languages for Documents
Select the languages used for the spelling checker, thesaurus, and hyphenation features of
LibreOffice. If these options are only for the current document, select For the current
document only.

Select Asian to enable support for Asian languages (Chinese, Japanese, Korean). Select
Complex Text Layout CTL to enable support for languages such as Urdu, Thai, Hebrew,
and Arabic. If you select either of these options, you will see some extra choices under
Language Settings the next time you open this dialog, as shown in Figure 35. These
choices (Searching in Japanese, Asian Layout, and Complex Text Layout) are not
discussed here.

€2 Note

An ABC icon in front of a language indicates that a spelling dictionary, thesaurus, and
hyphenation dictionary are activated for this language.

Enhanced Language Support — Ignore system input language
Default language settings depend on the locale setting. The default locale is based on that
of the computer’s operating system. A keyboard layout is normally based on the language
used by the operating system but can be changed by the user. If this option is not selected,
and there is a change in keyboard layout, input from the keyboard will be different from
what is expected.

Choose spelling options

To choose the options for checking spelling, click Language Settings > Writing Aids.

For details on using the Available Language Modules and User-defined dictionaries sections,
please see the Help.

In the Options section of the page (Figure 37), choose the settings that are useful for you.

Awzilable language modules

Hunspell 5pellChecker Edit...
Lightproof grammar checker (English]
Libhyphen Hyphenator
MyThes Thesaurus

User-defined dictionaries

New..
en-US [English (USA]]
technical [All] Edit...
List of Ignored Words [All]
Delete

Options
Check spelling as you type A Edit...
Check grarmrar as you type

Check uppercase words

[ theck words with numbers

Check special regions hd

Get more dictionaries onling...

Figure 37: Choosing languages, dictionaries, and options for checking spelling
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Some considerations:
* If you want spelling checked while you type, you must have Check spelling as you type
enabled.

» If you want grammar to be checked as you type, you must have Check grammar as you
type enabled, too.

* If you use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words
with numbers.

* Check special regions includes headers, footers, frames, and tables when checking
spelling.

Here you can also select which user-defined (custom) dictionaries are active by default, and add
or remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed
by the system cannot be deleted.

English sentence checking

On the Language Settings — English Sentence Checking page (Figure 38), you can choose which
items are checked for, reported to you, or converted automatically.

After selecting the additional grammar checks, you must restart LibreOffice for them to take
effect.

Grammar checking

DEDssihle mistakes Dgapitalizaticun

] Word duplication ] Parentheses
Punctuation

[~] Word spacing [] Em dash

[ Quotation marks [ Multiplication sign

[ Sentence spacing [] En dash

[] Apostrophe L] Ellipsis

L] More spaces L] Minus sign
Others

L] Convert to metric (°C, kmn/h, m, kg, [)
[ Thousand separation of large numbers
L] Convert to nen-metric (°F, mph, ft, 1b, gal)

Figure 38: Choosing options for checking sentences in English

Grammar checking

Possible mistakes
Checks for things such as subject-verb conflict, mood, tense; “with it's”, “he don't”, “this
things” and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.

Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.

Parentheses
Checks for pairs of parentheses and quotation marks.

Chapter 2 Setting up LibreOffice | 59



Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more spaces than that.

Quotation marks
Checks for correct typographical double quotation marks.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

Apostrophe
Replaces an apostrophe with the correct typographical character.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced
en dash to replace a non-spaced em dash.

Multiplication sign
This option is selected by default. It replaces an ‘x’ used as a multiplication symbol with the
correct typographical symbol.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, depending on
the locale setting for the document. One uses the comma as a thousands separator; the
other is ISO format, which uses a narrow space as a separator.

Other languages sentence checking

LibreOffice can also check sentences in other languages, notably Hungarian, Russian, and
Brazilian Portuguese. These checkers are enabled by default if the language is the computer’s
default language. The rules available for these sentence checkers depend on the language.

Choosing Internet options

The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.

If you are using Linux or macQS, an additional page of Email options is available, where you can
specify the program to use when you send the current document as email. Under Windows, your
default email program is always used.

To suppress (exclude) hidden elements such as tracked changes, hidden sections, hidden tabs in
a spreadsheet, or hidden layers in a drawing, select the Suppress hidden elements of
documents option.
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LibreOffice
¥ Load/Save
General E-mail program: |/usr/bin/thunderbird
VBA Properties
Microsoft Office
HTML Compatibility
Language Settings
LibreOffice Writer
LibreOffice Writer/Web
LibreOffice Base
Charts
Internet
Proxy

Sending Documents as E-mail Attachments

B suppress hidden elements of documents
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Mediawiki

Figure 39: Internet options, showing E-mail page available to Linux users

A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the
Internet options, then click the Add button to open a dialog where you can specify the address
(URL) and login information for a wiki. You can add several wikis to the list. A JRE (Java Runtime
Environment) is needed for this feature to work.

Controlling LibreOffice’s AutoCorrect functions

LibreOffice’s AutoCorrect functions automatically detect and replace common symbols, spelling
mistakes, and grammar mistakes. Sometimes, AutoCorrect changes something that should have
been kept. If unexplained changes appear in your document, the AutoCorrect settings are often
the cause.

Click Tools > AutoCorrect > AutoCorrect Options to customize AutoCorrect. You must have a
document open for this menu item to appear. Use the tabs to add, edit, and delete AutoCorrect
options. In Writer, this dialog has five tabs. In other components of LibreOffice, the dialog has
only four tabs. Find more details in the relevant component guides.
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Introduction

There are two basic ways to format text and other elements. Understanding these two
alternatives is essential for unlocking the power of LibreOffice:

Direct (or manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, tables,
cells, and other elements. For example, you can select a word, then click on a button on
the Formatting toolbar to format the text as bold or italic.

Styles
Bundles formatting options under one name. For example, a paragraph style defines
numerous settings for options such as font type and size, whether paragraphs should be
indented, the space between lines, how paragraphs should be aligned on the page, and
many others.

Using styles is highly recommended

LibreOffice is a styles-based program. It may work somewhat differently from other programs you
are familiar with. Using styles effectively requires some planning, but the time spent in planning
can save time and effort over the longer term.

Because styles apply whole groups of formats at the same time, you can easily format a
document consistently and change the formatting of an entire document with minimal effort.
Styles are used by LibreOffice for many processes, even if you are not aware of them. For
example, Writer relies on heading styles (or other styles you specify) when it compiles a table of
contents. Some common uses of styles are given in “Examples of style use” on page 80.

What are styles?

A style is a set of formats that you can apply to selected elements such as pages, text, frames,
cells, and others in a document to quickly set or change their appearance. Applying a style often
means applying a group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their
documents without paying any attention to styles. They are accustomed to manually applying
attributes such as the font family, font size, and any formatting such as bold or italic.

Using styles means that instead of applying “font size 14pt, Times New Roman, bold, centered”
you can apply (for example) a “Title” style, because you have defined the “Title” style to have
those characteristics. In other words, using styles means that you shift the emphasis from what
the text (or page, or other element) looks like, to what the text is.

Note

Direct formatting overrides styles. You cannot remove manual formatting by applying
a style to it. To remove direct formatting, select the text, right-click, and choose Clear
Direct Formatting from the context menu. Alternatively you can clear direct
formatting from selected text by pressing Ctrl+M (Ctrl+Shift+M in Impress), by
selecting Format > Clear Direct Formatting on the Menu bar, by selecting the
Clear Direct Formatting icon on Writer's Formatting toolbar, or by selecting the
Clear Direct Formatting icon on Calc’s Standard toolbar.
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Types of styles in LibreOffice
LibreOffice supports the following types of styles:

Page styles include margins, headers and footers, borders and backgrounds. In Calc,
page styles also define the sequence for printing sheets.

Paragraph styles control all aspects of a paragraph’s appearance, such as text
alignment, tab stops, line spacing, and borders, and can include character formatting.

Character styles affect selected text within a paragraph, such as the font and size of
text, or bold and italic formats.

Table styles apply predefined formats to tables and table elements in a text document.

Frame styles are used to format graphic and text frames, including text wrap, borders,
backgrounds, and columns.

List styles allow you to select, format, and position numbers or bullets in lists.

Cell styles include fonts, alignment, borders, background, number formats (for example,
currency, date, number), and cell protection.

Drawing styles in drawings and presentations include line, area, shadowing,
transparency, font, connectors, dimensioning, and other attributes.

Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 2.

Details

are given in the user guide for each component.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them,
or create new ones, as described in this chapter.

Table 2. Styles available in LibreOffice components

Style Type Writer Calc Draw Impress

Page

X

Paragraph

Character

Frame

List

Table

XX X | X | X]|X

Cell

Presentation X X

Drawing X X

Applying styles

LibreOffice provides several ways for you to select and apply styles:

Styles deck in the Sidebar

Fill Format Mode

Styles menu (Writer and Calc)

Set Paragraph Style list (Writer) and Apply Style list (Calc) on the Formatting toolbar
Keyboard shortcuts
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Styles deck in the Sidebar

The Styles deck includes the most complete set of tools for styles. To use it for applying styles:

1) Select View > Styles or Styles > Manage Styles on the Menu bar, or press F11 (38+T on
a Mac), or click the Styles tab on the Sidebar (View > Sidebar to open it).

The Styles deck optionally shows previews of the styles available. Figure 40 shows the
panel for Writer, with Paragraph Styles visible and with previews off.

2) Select one of the buttons at the top left of the Styles deck to display a list of styles in that
category.

3) To apply an existing style, position the insertion point in the paragraph, frame, page, or
word, and then double-click the name of the style in one of these lists. To apply a
character style to more than one word, select the characters first.

@ ip
At the bottom of the Styles deck is a drop-down list where you can select what styles
will be listed in the Styles panel. In Figure 40 the list shows All Styles defined for the

document. It could show Applied Styles (only the styles used in the document) or
other groups of styles, for example Custom Styles.

e - Mew Stye from Selection
Paragraph Styles ==& ¢ § § 4 : Update Selected style
Character Styles wsug Load Styles

Eredncite
First ILine Igdes

Frame St}rlea-i- Fill Format Mode

Page Styles -|-
List Styles i

Table Styes

Header

Shivay Prawnews

Pl seyles 1= |
Hierarchical

Condibonal Siyles

Figure 40: The Styles deck for Writer, showing paragraph styles and filter

Fill Format mode

Use Fill Format mode to apply a style to many different areas quickly without having to go back to
the Styles deck and double-click every time. This method is quite useful when you need to format
many scattered paragraphs, cells, or other items with the same style:

1) Open the Styles deck and select the style you want to apply.
2) Click the Fill Format Mode button at the top of the Styles deck.

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page,
or frame and click.
To apply a character style, hold down the mouse button while selecting the characters.
Clicking a word applies the character style for that word.
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4) Repeat step 3 until you have applied that style everywhere you desire.
5) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.

Styles menu (Writer and Calc)

In Writer, the Styles menu has the most commonly used paragraph, character, and list styles for
text documents, as well as entries for style management. The Styles menu does not have styles
for frames, pages, or tables.

To apply a paragraph style, position the cursor anywhere in the paragraph, and then select one of
the paragraph styles in the Styles menu. To apply a character style to several characters or more
than one word, select the characters first and apply the character style from the menu.

In Calc, the Styles menu has cell styles and style management entries. To apply a cell style,
select the cell or group of cells to be formatted, and then select the required style.

Set Paragraph Style list (Writer) and Apply Style list (Calc)

In Writer, after you have used a paragraph style at least once in a document, the style name
appears in the Set Paragraph Style list at the left-hand end of the Formatting toolbar.

In Calc, after you have used a cell style at least once in a spreadsheet, the style name appears in
the Apply Style list at the left-hand end of the Formatting toolbar. If the Apply Style list is not
visible, you can enable it using one of the methods given in “Customizing toolbars” in Chapter 1,
Introducing LibreOffice.

You can open this list and click the style you want, or you can use the up and down arrow keys to
move through the list and then press Enter to apply the highlighted style.

eTip

Select More Styles at the bottom of the list to open the Styles deck on the Sidebar.

B-B-E- 1B -
| Text Body [ & | Liberation ¢
. Text Body -
] Quotations

~ Title

1 Subtitle

Heading 1

Heading 2

Heading 3

22

23

Contents 1

4 Contents 2

—~_ s

Figure 41: The Set Paragraph
Style list in Writer

Keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0
applies the Text Body style, Ctri+1 applies the Heading 1 style, and Ctr/+2 applies the Heading 2
style. You can modify these shortcuts and create your own; see Chapter 14, Customizing
LibreOffice, for more details.
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Creating and modifying styles

LibreOffice includes some predefined styles, but you can also create custom styles. You can
modify both predefined and custom styles in several ways:

* Change a style using the Styles deck

* Update a style from a selection

» Use AutoUpdate (paragraph and frame styles only)
* Load styles from another document or template

Note

Any changes you make to a style are effective only in the current document. To
change styles in more than one document, you need to change the template.

Changing a style using the Styles deck

To change an existing style using the Styles deck on the Sidebar, right-click on the required style
and select Modify in the context menu.

A Style dialog is displayed with title, content, and layout dependent 